Jump to content

Just lost $30 Million randomly as I logged in today


Jack Grist
 Share

Recommended Posts

Hello, yesterday I had $1 Billion (give or take a million), and as i've logged into my nation today I have $970 Million. I try not to go below a float of $1 Billion, and also I had brought a wonder a few days ago so I couldn't of bought another yesterday (I would of also remembered if I had done :P). I've checked infrastructure, land and technology levels and they all look the same as they did yesterday.

I don't know how you guys can fix this, or if you guys can find out whats actually happened. It just kinda sucks to lose that amount of money randomly. Also is it actually possible that this was just a spy operation (a very successful one at that)? I don't even know if spies can take that much away anyway, and considering it was like $30 Million straight, just seems a bit too precise.

Any help from mods or the admin would be much appreciated, thanks.

(Oh, and yes, I haven't been on these forums in a loooongggg timeeeee hehe)

EDIT: I haven't collected my taxes or paid bills yet, so I didn't have like a huge bill increase, not that it would make sense if I did anyway.

Edited by Jack Grist
Link to comment
Share on other sites

If it was a spy operation, you would have received a message in your inbox.

So you haven't had any money transactions since you bought the wonder a few days ago? Did you recently move any Space Wonders?

Link to comment
Share on other sites

Yeah thats why I ruled out the spy operation.

And I had paid for that wonder a couple of days ago, and yesterday I had bought 10 levels of infrastructure and some land, which put me down to $1 Billion, and I wouldn't buy anything else after that because as I said, I like to keep it 1 Billion or above as a safety net. I also didn't move any space wonders or anything like that, this is why I am so confused.

Link to comment
Share on other sites

Oh my god...... :blink:

Yeah, they are around that...and haha, this is embarrasing...

I've obviously paid my bills first (without giving it much notice), left it for a while, gone on facebook, checked emails, came back to it and thought 'WHERE'S 30 MILLION GONE?' It's weird cause I never pay bills first, I always collect taxes first, so I know where i've gone wrong.

Sorry guys :rolleyes:. Maybe I need to pay attention to what i'm doing more! xD Thanks for pointing that out, although collecting my bills afterwards would of really solved the 'mystery' straight away without needing to go on the forums. Haha, yeah this can be closed, or deleted :P

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...